[Clg] Problème sur le site Web

Jean-Marc Vaillancourt jmv at securinux.com
Mar 20 Mar 00:22:08 EDT 2012


OK, la seule modification qui a été faite au serveur depuis
l'installation de la dernière version de PHP a été la modification d'une
ligne dans un fichier de Drupal pour empêcher les messages d'erreur
d'apparaître. En passant, php-5.3 a été installé la semaine dernière
lors d'une mise à jour, parce que Gentoo ne supporte plus la version
5.2. J'aurais pu empêcher cette installation, mais ça aurait
probablement causé d'autres problèmes (c.-à-d. un serveur pas à jour et
donc vulnérable).

Je peux remettre le fichier à son état original et tout copier dans un
autre répertoire pour en faire un site de test.

J-M
P. S. Je viens de recevoir ton autre message (aider par téléphone). Bien
d'accord. Je prépare le tout et je te fais signe. Le plus difficile sera
de trouver un moment qui nous convient ;-)
Le 2012-03-19 16:22, Jacques Dery a écrit :
> Revenir à l'état original: Eliminer toutes modifications apportées au
> serveur depuis que tu as installé la dernière version de PHP avant d'aller
> de l'avant avec la mise-à-jour.
>
> Jacques
>
> 2012/3/18 Jean-Marc Vaillancourt <jmv at securinux.com>
>
>>  Salut Jacques,
>>
>> Merci pour tes suggestions. Je n'avais pas l'intention de passer à la
>> version 7 directement, je ne suis pas assez fou pour ça! Et je pensais
>> également faire la mise à jour sur un site de test. Mais j'aimerais savoir
>> ce que tu entends par revenir à l'état original du site.
>>
>> Je dois ajouter que ce que je crains le plus, c'est la migration de la
>> base de données de Drupal 5 à Drupal 6.
>>
>> En tout cas je sais qu'avec le peu de temps dont je dispose, l'opération
>> sera longue!
>>
>> J-M
>> Le 2012-03-18 14:48, Jacques Dery a écrit :
>>
>> Bonjour Jean-Marc,
>>
>> Même si elle est assez sécuritaire, la version courante, 5.23, n'est plus
>> supportée.
>>
>> On devrait migrer de façon structurée pour passer à Drupal 6 et ensuite à
>> Drupal 7 car attendre ne fera qu'empirer le problème.
>>  Voici ma recommendation. Elle comporte plus de chance de succès car moins
>> risquée (même si elle est plus compliquée):
>>
>>    - Revenir à l'état original du site.
>>    - Créer un sous domaine avec un site de test
>>    - Implémenter les changements sur le site de test:
>>    - Mettre-à-jour à Drupal 6.
>>       - Documenter la mise-à-jour sur le site web
>>       - Migrer quand on a déterminé ce qui fonctionnera et ce qu'on
>>    abandonnera.
>>    - Mettre à jour à Drupal 7 en utilisant le même processus. Avec
>>    l'expérience acquise et la documentation, on sera en meilleure posture.
>>
>> L'avantage de cette approche est que le site de test est utilisable et
>> disponible pour tester de nouvelles fonctionnalités (modules contribués).
>> Jacques
>>
>> 2012/3/18 Jean-Marc Vaillancourt <jmv at securinux.com> <jmv at securinux.com>
>>
>>   Salut tout le monde,
>>
>> Le site Web fonctionnait plutôt bien jusqu'à tout récemment. Dernièrement,
>> j'ai effectué une mise à jour qui installé php-5.3, en laissant php-5.2 en
>> place et en me laissant le choix d'utiliser l'un ou l'autre. C'est bien,
>> parce que Drupal (5.23), notre gestionnaire de contenu, fonctionne
>> justement avec php-5.2 et est plus ou moins compatible avec la version plus
>> récente. Le problème, c'est que php-5.2 fait charger la bibliothèque
>> (library, en bon anglais) libpng14, que php-5.3 a fait disparaître pour la
>> remplacer par libpng15, ce qui empêche Apache de démarrer, puisque son
>> module php est lié à php-5.2.
>>
>> Si j'utilise php-5.3, Apache démarre, mais un paquet de messages d'erreur
>> apparaissent sur les pages Web du site. Bon, ok, on n'en voit (presque)
>> plus maintenant parce que j'ai trouvé le moyen de ne plus les faire
>> afficher en "tweakant" un fichier de Drupal. Non, je n'ai rien inventé,
>> j'ai trouvé ça sur Internet. Mais ça n'a pas fait disparaître le problème
>> d'incompatibilité, ça a seulement fait disparaître les messages.
>>
>> De plus, Gallery, le module de photos intégré à Drupal, est totalement
>> incompatible avec php-5.3. Je l'ai désactivé pour l'instant. On pourrait
>> également s'en débarrasser et ça ne changerait pas grand chose, je pense.
>>
>> J'en arrive donc à la conclusion qu'il faudra mettre Drupal à jour (6,
>> 7?). Facile. Mais la migration des données vers la nouvelle version le sera
>> moins! J'ai fait une sauvegarde de la base de données. Il me reste à faire
>> une sauvegarde des fichiers. J'ai commencé à lire la documentation sur la
>> migration de la version 5 à la version 6 ( http://drupal.org/node/340073).
>> Mais j'aurai besoin d'aide (Jacques?, Claude?), surtout pour la
>> manipulation de la base de données.
>>
>> Alors j'attends vos propositions et suggestions. En attendant, allez faire
>> un tour sur le site. Vous ne devriez pas y voir grand chose d'anormal, sauf
>> pour ceux qui se connecteront avec des droits d'administrateur.
>>
>> J-M
>>
>> _______________________________________________
>> Clg mailing listClg at linux-gatineau.orghttp://www.linux-gatineau.org/mailman/listinfo/clg
>>
>>
>>
>> _______________________________________________
>> Clg mailing listClg at linux-gatineau.orghttp://www.linux-gatineau.org/mailman/listinfo/clg
>>
>>
>>
>> _______________________________________________
>> Clg mailing list
>> Clg at linux-gatineau.org
>> http://www.linux-gatineau.org/mailman/listinfo/clg
>>
>>
>
>
> _______________________________________________
> Clg mailing list
> Clg at linux-gatineau.org
> http://www.linux-gatineau.org/mailman/listinfo/clg

-------------- section suivante --------------
Une pièce jointe HTML a été nettoyée...
URL: <http://www.linux-gatineau.org/pipermail/clg/attachments/20120320/be08f66e/attachment.htm>


Plus d'informations sur la liste de diffusion Clg